
Power up your Ivium instrument and connect it to the PC via the USB cable that is
included in the instrument shipment.

All Ivium instruments have a unique serial number that can be found on its serial
number tag. Once the instrument is powered up, this number will appear in the top-
left of your IviumSoft. If multiple instruments or a multichannel instrument are
connected, all (channels) will be shown and can be selected from the drop-down
menu. Once selected, the potentiostat/channel can be connected to the IviumSoft
by clicking the adjacent "Connect" button. Upon connection the instrument/channel
and IviumSoft will be synchronised, and the appropriate functions in IviumSoft will
be activated. Your instrument is now ready for use.

NOTE 1: Chances are that your downloaded version of IviumSoft is newer than
the instrument was shipped with. You will get a pop-up upon connection
that you should update the instrument firmware. Do not ignore this, but
follow the instructions in Section E of this document.

NOTE 2: Specific operating instructions for your instrument can also be found in
the IviumSoft helpfile, see Section F of this document.

NOTE 3: For multichannel Ivium potentiostats and cyclers, Iviumsoft offers
different options to control multiple channels separately and
simultaneously. For these advanced operations please refer to the
manual/Helpfile in IviumSoft or other Ivium documentation.

A/Software installation

1) Install IviumSoft:

The full IviumSoft installation package of the most
recent version can be downloaded from the Ivium
website at: https://www.ivium.com/support/

Unpack and execute the "IviumSoftSetup.exe".
IviumSoft will be installed on your C-drive (default)
in the "IviumStat" folder. This folder will include
example data files, drivers, Labview example and
the IviumSoft Helpfile/Manual.

During the installation, all necessary instrument
drivers are installed (see screenshot to the right). If
you notice that not all drivers are installed
correctly, your Windows (security) settings are
blocking a proper installation and you should
contact your IT department.

Upon completion of the installation a shortcut to
IviumSoft will be placed on your desktop and
IviumSoft will be started.

B/Connecting your instrument

C/ Software – user interface

1. Device & software control
2. Operating parameters
3. Advanced parameters
4. Measurement results
5. Legend panel
6. Data file history list
7. Status bars

1. Device & software control

The menu bar:

File - Data and method file management.
Options - Setting the device and data handling options, incl. FRA options
Tools - Device maintenance and special operations
Help - Gives access to the HTML help file/user manual
About - Shows: IviumSoft release version [corresponding .dll no#] 

(firmware versions)

To start: 
a. In the drop down menu 
select the device by Serial Number.
b. To operate this instrument, click "Connect".

2. Operating parameters

"Direct" mode: for direct control of the instrument

• Intended for diagnostic purposes
• Actual potential and current are displayed
• When not controlled, the open cell potential is displayed

(within specified accuracy)

"Method" mode: for executing electrochemical methods.

Example:
a. Select configuration, i.e. "Cell Estat4".
b. Select current range
c. Insert value
d. Press "Apply"
e. Check connect-box: cell on/off

f. Above:
DC/AC - to toggle between AC/DC signal measurement
IRcorr - will open IR-drop correction window
HiSens - will make hi-sensitivity current ranges available

g. Below: direct control of the peripheral port and FRA are
possible.

Example:
a. Select desired method from the tree:

Expand method group and select method.
b. The relevant method parameters are listed and accessible

in the window below.
c. Once the desired parameters are set the measurement can

be started by clicking the "Start" button
at the bottom of the window.

d. Clicking the "Abort" button will abort the measurement
immediately at the next data point.

e. When preconditioning before measurement is set up,
directly after clicking "Start" a "Continue" button will
appear. Clicking this will terminate the preconditioning and
proceed to start the method.

f. Data is continuously saved during the measurement. Upon
finishing and/or aborting the measurement, a data file is
generated with an automatically generated file name.

g. A method with desired parameters can be saved for future
use by selecting "File" in the menu bar and choosing "Save
method".

h. From Menu > File previously saved methods and data files
can be loaded. When loading a data file also the
corresponding method is loaded. Clicking "Start" will re-
run the same experiment.

3. Advanced parameters

• In "Method" mode, by default the basic parameters are
shown. Selecting "Advanced" from the drop down menu
will add a number of advanced method parameters.

•MC Mode: will open a separate panel designed for
controlling many channels, for example for IviCycle
systems , refer to the help file/manual under:

• "SigView" opens a window that shows voltage and
current signal trace during an AC measurement, as
well as for saved impedance data points. Can be
used to verify the quality of the signal and to
check for e.g. overload/oscillation situations.

4. Measurement results

•When a measurement is started the data is shown real time in the
result graph. A right mouse click on the graph will give the user a
number of options, including changing the graph colour and
background, as well as copying the graph to clipboard.

• The buttons to the left allow additional data to be displayed. Data is
by default displayed "2D"; "3D" and "3Di" display may also be
chosen. Clicking the "Cor" button after the measurement has
finished, will start the correction mode, allowing the user to change
individual data-points. "X" shows the primary data, "Ain, ocp, pre,
Q, Rs, Cs" will all open a secondary graph that shows the
corresponding data when available: optional analog inputs, ocp-
measurement before scan, pre-treatment data, etc.

• The "Scale" button allows the scale of the graph to be adjusted via
the drop down menu; clicking on the button itself will auto-scale
the graph.

• "Analysis" will make a number of analysis methods available to the
data in active memory.

• "Edit" will allow smoothing of the scan data.

• The buttons at the top of the graph activate different
representations of (impedance) measurement data.

• The tabs "Result graph" and "Result data" above the graph enable
switching between graphical and numerical representation of the
scan data. "E scan" will show the data for analysis when an
impedance-scan method has been carried out.

5. Legend panel

"Scan" shows the list of scans that have just been measured or loaded from memory.
"Hide all"/"Show all" will respectively hide and show all scans in the list.
In the list of scans, checking/unchecking the box next to the scan will show/hide
individual scans. Note that the scan that is highlighted blue is the scan in active
memory. This is the one that is evaluated in "Analysis", or has the numerical
data shown in "Result data", etc. Clicking on a different scan will select that one
(highlight it), making it available for analysis, saving, etc.
Checking the box before "Hide previous" will hide all previous scans, except the
latest (useful when a large number of scans is listed).
"All extra data" will show the extra data, for example OCP measurement, of all
scans in the list.
"Delete" will remove the selected scan from the view screen only*.
"Delete all" will remove all scans from the view screen only*.

*Data is always automatically stored in a datafile and cannot
be permanently deleted from the Legend panel

"Load DB" will load data from the Database file rather than the .idf file; useful
when datareduction is applied. For more details see IviumSoft Helpfile
"Data appear" will allow user to change the appearance of the data: lines,
colours, symbols.

The "Chan" tab shows when analog inputs are sampled (advanced method
parameter), it allows the user to show/hide analog channels in the second graph.
"Olay" will allow the user to load data from file and overlay it so that it can be
compared to the scan data that was just recorded. Several scans can be overlayed
at the same time. Overlayed data is not available for analysis.

Three tabs:
1)

2)

3)

Note that:
- A scan in the list can be selected (highlighted in blue), but not be visible in the

graph, and vice versa.
- When different electrochemical methods are used, the data cannot always be

represented in the same graph (i.e. CV and EIS data). For this reason, the format
of the most recent scan in the Legend panel is automatically displayed and only
compliant scans are shown. Non-compliant scans are hidden. Holding the [ctrl]
while clicking a scan will change the graph format to show that data.

- Starting a CV-scan will automatically clear the graph of all present scans; All other
techniques/methods will add the new scan to the Legend panel.
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• The "Project window" shows the active Project directory
in which data files are automatically stored. Select your
Project directory from the drop down menu. When typing
a new Project name in the window, it will automatically
be created when the next data file is stored.

• "BatchMode" opens the batch programming window.
This can be used for automating and sequencing
measurements, scheduling events, etc. For
instructions, refer to the help file/manual under:

Instrument control > Batch Mode

• Toggle between
IviumSoft and
CycliScan: the
dedicated battery
testing module in
IviumSoft. For
CycliScan see
other side of this
document
(section D).
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Instrument control > MC Mode
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E/ Special operations

From the top "Tools" menu, a list of special operations will open: 

"Performance test" (only available when an instrument is connected)

"Performance test" will open a pop-up window that allows a
self-diagnostic test of the instrument. This test is intended for
occasional use, for example to determine if the calibration is
still correct or whether the instrument is in proper working
order. At a service request you can be asked to run this test
by an Ivium service engineer to determine if the problem is
hardware related. The performance test can only be executed
when the instrument is in the "standard" configuration (= no
extended range or other instrument options activated).

To perform the test, connect the cell cable to Testcell1,
uncheck all options in the menu "Options>Options", and press
"Run test" in the pop-up. All status reports should read
"Pass". If one or more reads "Fail" after repetitive runs, the
instrument may need calibration. This cannot be done by the
user, you should contact your supplier.

The test report is stored in your\IviumStat directory as a text
file with the file name: [Serial number].ipt

F/ Device control & Software/Firmware upgrade

IviumSoft upgrade

IviumSoft is frequently updated with new features, and new versions are published on our website at:
www.ivium.com/support. Here the new version can be downloaded as .zip file. The .zip file contains the full
IviumSoft installation suite.

To upgrade the IviumSoft, download the latest version of the software from: www.ivium.com/support. Unzip the
file and run the IviumSoftSetup.exe. Following the instructions will install the latest version of IviumSoft and
drivers, but will leave your existing Ivium data- and other files intact.

Now your IviumSoft has been upgraded. After this proceed to upgrade the firmware of your instrument.

Firmware upgrade

Ivium instruments are equipped with an internal microPC that operates the electronics, and is used to store data
during a HiSpeed experiment. The firmware that runs on the microPC is specific to the version of IviumSoft. For
correct communication (and operation) these versions need to match, that is why IviumSoft has the correct
version of firmware embedded. To upgrade the firmware of your instrument:

6. Data file history list

All Ivium measurement data is continuously saved and a datafile is generated upon completion or user-abort of a
measurement. The datafile name is automatically generated based on a unique scan id, instrument S/N, date, etc.
After the data is saved to file in the active project, it will be added to the history list of most recent data files at
the bottom of the user interface.

Double clicking on a file in the history list will load that file into the result window. Holding the [Shift] key will allow
multiple data files to be selected simultaneously. A right mouse click will open a pop-up:

• Load Scans: will load selected scans into the result window.
• Add Scans: will add selected scans to the result window and the scans already there.
• Add Overlays: will load selected scans to the result window but into the Olay tab, in stead of the Scan tab.
• Copy files: will copy data file to clipboard, for example for easy pasting into an e-mail, or a file directory.
• Add to/Remove Bookmark(s): will add/remove the selected scan to/from the bookmarks for future reference.

Book marked scans can be identified by their underline. All bookmarked files in the history list can be shown by
clicking [Bmrks] to the left of the history list.
•Move to active project: will move the data file to the active project (see 3. Advanced parameters).
•Move to project: allows to move the data file to any available project.
•Move to tempfiles: will move the data file to the tempfile directory. Data files in the "tempfile" project are

displayed in red.
•Delete permanently: will delete the .idf/.ids data file permanently.
•Open file location: opens the location of the data file in Windows explorer.

Data Storage: Data is stored real time in a sqlite Database file and in an .idf/.ids file upon completion or abort in
IviumSoft. All Data files are stored in a Library\project structure. In the menu "File>Data (DB) Explorer" Data
(Base) files in all libraries and projects can be explored, with a list of method parameters and result graph preview.
In the menu "Options>Datahandling Options" more data storing options can be specified, such as: Library, Project,
automatic CSV file creation, nr. of visible scans, automatic storage of a file copy to another designation (i.e.
network drive), temp file properties, etc.
More information on Data file/saving is available in the Helpfile:

"Define channels"

"Define channels" is only available for the Ivium-n-Stat
multichannel potentiostat: it will open a pop-up window that
allows the user to assign an easy designation (rather than the
serial number) to each channel. Details on how to do this can
be found in the IviumSoft Help:

1. Connect to your instrument in the IviumSoft and go to
"Tools > Update Firmware"

2. In the pop-up window click on "Start Firmware upgrade"

After an experiment is completed
and the datafile is stored, the user
can enter a description and click
"Apply" to store the description in
the view of the history list.

Checking the bookmark box and
pressing "Apply" will bookmark the
selected datafile for future reference.
Bookmarked files are underlined.

7.A and B: Status bars

Status bars are located at the bottom of the user interface and below Advanced parameters:

• Real time E, I, number of acquired data points, cycle number, elapsed runtime, etc.

In addition to the brief overview of the IviumSoft user interface that is given in this Quick guide, in-depth
information is given in the digital help file/manual that is included in your IviumSoft. There you will find
instructions on the installation of potentiostats and modules, their instrument specifications, and how to operate
them. In addition detailed information on how to use IviumSoft and all its functions regarding operating all
electrochemical techniques and measurement methods, data representation and evaluation, etc., is described.

To access the digital Help file/Manual open your IviumSoft and press "F1". The help file is partly content sensitive
so indicating with your cursor an area or subject in the IviumSoft user interface and subsequently pressing "F1"
will open the helpfile on the relevant subject.

In the help file/manual the subjects are structured in main chapters according to:

Electrical Compliance

Introduction

IviumSoft

Getting started

Instrument control

Electrochemical
techniques

Measurement Results

Data files

Special functions

Software upgrade

Control via
other software

Trouble shooting

Instrument
specifications

Method parameters

NOTE 1:
It may be that when you open the help file the content is not visible, or you see a cryptic browser message like
"Navigation to the webpage was cancelled" or "Action cancelled". This is caused by Windows and can be fixed
simply by changing a setting: In Windows explorer navigate to your IviumStat directory where the help file is
located. Right-mouse-click on the 'IviumSoft.chm' file and choose 'Properties' at the bottom of the list. This opens
a pop-up. In the bottom panel of the pop-up click "Unblock" and OK. Close the pop-up window. Now the content in
the IviumSoft help will be available.

NOTE 2:
The help file/manual covers current IviumSoft and instruments and operations. If you have specific operating or
instrument specification questions regarding older versions of Ivium instruments, please contact Ivium.

NOTE 3:
A (printable) PDF-version of the digital IviumSoft Help is available in the 'Manuals and Release Notes' directory in
the 'IviumStat' installation directory on your PC. This PDF is not updated as often as the help file.

G/IviumSoft Help-file/Manual

Declaration of CE conformity of Ivium instruments.

Brief description of Ivium, our instruments and the working principle of IviumSoft.

Detailed description of IviumSoft: how to operate the software, instructions on the 
user interface, data representation and options, how to select and set instrument 
options and operations.

Instructions for first time installation: IviumSoft and Ivium equipment, instrument 
drivers and configuring your Windows system, product-specific information for all 
Ivium potentiostats and modules, how to connect the electrodes and internal 
integrated dummy cells.

Description of how the user can control Ivium potentiostats through IviumSoft: 
directly for diagnostic purposes or via user selectable electrochemical methods; how 
to program a sequence of events in the Batch programming mode; special 
instrument functions; sequence of execution of the various commands by the 
potentiostat.

Brief description of all available electrochemical techniques (for detailed descriptions 
the electrochemical textbooks should be consulted), grouped by:
Linear sweep, Cyclic voltammetry, Transients (CA, CP, ECN, MixedMode, CycliScan), 
Electroanalysis, Impedance, Corrosion.

How to access and represent the measured data (graphic and numeric), as well as 
the various available data evaluation techniques and possibilities.

How and where data files are stored and accessed; the structure of projects and 
libraries; the handling of very large data files and automatic saving of data.

Special operations for (instrument) diagnostics and maintenance, preparatory 
techniques and use of the peripheral port signals and functions.

Instructions for IviumSoft upgrade.

Description on the software development driver and dll for control via other software 
such as Labview, C++, VB, etc.

How to solve some of the most frequently encountered issues and how to restore 
your potentiostat.

Specifications of all Ivium instruments, modules, accessories and their compatibility.

Detailed description of all method parameters.
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see 
item F

For more instructions, how to recover from a failed firmware upgrade, or how to restore your instrument to
factory settings, please refer to the help file/manual: Trouble shooting

"Calibrate cable"

This function will allow you to calibrate your specific cell cable
only if you have the Ivium calibration cell. Cell cable
calibration is especially useful for EIS on low impedance
objects at higher frequencies to compensate for inductance
effects. Contact Ivium for more information.

see 
Helpfile

D/Ivium CycliScan 

IviumSoft contains an integrated module especially designed for battery cycling: Toggling to "CycliScan" in the top
menu bar (or selecting "CycliScan from the transient techniques) will open an editing window and hide the method
tree. The editing window can be undocked from IviumSoft to enlarge the result graph. For a detailed description and
all possibilities of CycliScan please refer to the IviumSoft Help file.

Number of tasks per scan Number of cycles the scan is repeated Dock or Undock the Edit window

Design a scan for this instrument; checks settings against instrument capability when instrument is not connected.

Setting: Instrument E/I range settings
Meas: Data acquisition settings
Data: Battery data (capacity,density,etc.)
Limits: Global safety limits (E,I,Temp,etc.)
Report: Data and time stamp, remarks and notes 

Task field:
Build your battery test routine here. 
Charge/discharge, CC, CV, CR, CP, OCV, EIS, 
LSV, local limits, loops, go-to, profile, pulse, 
etc.

Data files

A

B

• Overload conditions during measurement; 
• User selected instrument options and external modules (menu Options>Options)

IviumSoft>Tools menu

3. The Firmware will now
automatically start to upload.
When the "Close" button
becomes available again, the
Firmware upgrade is finished.
Click "Close" to reboot the
instrument. Reconnect your
instrument in IviumSoft; it is
now ready to go.
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